CVE-2025-4230 PAN-OS: Authenticated Admin Command Injection Vulnerability Through CLI
🔗 CVE IDs covered (1)
📋 Description
A command injection vulnerability in Palo Alto Networks PAN-OS® software enables an authenticated administrator to bypass system restrictions and run arbitrary commands as a root user. To be able to exploit this issue, the user must have access to the PAN-OS CLI. The security risk posed by this issue is significantly minimized when CLI access is restricted to a limited group of administrators. Cloud NGFW and Prisma® Access are not affected by this vulnerability.
🎯 Affected products3
- Cloud NGFW
- PAN-OS
- Prisma Access
✅ Remediation
VERSION MINOR VERSION SUGGESTED SOLUTION Cloud NGFW All No action needed. PAN-OS 11.2 11.2.0 through 11.2.5 Upgrade to 11.2.6 or later. PAN-OS 11.1 11.1.0 through 11.1.6 Upgrade to 11.1.6-h14 or 11.1.10 or later. PAN-OS 10.2 10.2.0 through 10.2.10 Upgrade to 10.2.10-h27 or later. PAN-OS 10.1 10.1.0 through 10.1.14 Upgrade to 10.1.14-h15 or later. All older Upgrade to a supported fixed version. unsupported PAN-OS versions Prisma Access All No action needed. Workarounds and mitigations: No workaround or mitigation is available.