CVE-2025-0141 GlobalProtect App: Privilege Escalation (PE) Vulnerability
🔗 CVE IDs covered (1)
📋 Description
An incorrect privilege assignment vulnerability in the Palo Alto Networks GlobalProtect™ App on enables a locally authenticated non administrative user to escalate their privileges to root on macOS and Linux or NT AUTHORITY\SYSTEM on Windows. The GlobalProtect app on iOS, Android, Chrome OS and GlobalProtect UWP app are not affected.
🎯 Affected products2
- GlobalProtect App
- GlobalProtect UWP App
✅ Remediation
VERSION MINOR VERSION SUGGESTED SOLUTION GlobalProtect App 6.3 on macOS 6.3.0 through 6.3.3 Upgrade to 6.3.3-h1 (6.3.3-c650) or later. GlobalProtect App 6.3 on Windows 6.3.0 through 6.3.3 Upgrade to 6.3.3-h1 (6.3.3-c650) or later. GlobalProtect App 6.2 on macOS 6.2.0 through 6.2.8 Upgrade to 6.2.8-h2 (6.2.8-c243) or later. GlobalProtect App 6.2 on Windows 6.2.0 through 6.2.8 Upgrade to 6.2.8-h2 (6.2.8-c243) or later. GlobalProtect App 6.1 on macOS Upgrade to 6.2.8-h2 (6.2.8-c243) or 6.3.3-h1 (6.3.3-c650) or later. GlobalProtect App 6.1 on Windows Upgrade to 6.2.8-h2 (6.2.8-c243) or 6.3.3-h1 (6.3.3-c650) or later. GlobalProtect App 6.0 on macOS Upgrade to 6.2.8-h2 (6.2.8-c243) or 6.3.3-h1 (6.3.3-c650) or later. GlobalProtect App 6.0 on Windows Upgrade to 6.2.8-h2 (6.2.8-c243) or 6.3.3-h1 (6.3.3-c650) or later. GlobalProtect App 6.2 on Linux 6.2.0 through 6.2.7 Upgrade to 6.2.8 or later. GlobalProtect App 6.1 on Linux Upgrade to 6.2.8 or later. GlobalProtect App 6.0 on Linux Upgrade to 6.2.8 or later. GlobalProtect App on Android, Chrome OS, iOS No action needed. GlobalProtect UWP App No action needed. Workarounds and mitigations: No workaround or mitigation is available.