CVE-2024-9471Medium

CVE-2024-9471 PAN-OS: Privilege Escalation (PE) Vulnerability in XML API

Published
October 9, 2024
Last Modified
October 9, 2024

🔗 CVE IDs covered (1)

📋 Description

A privilege escalation (PE) vulnerability in the XML API of Palo Alto Networks PAN-OS software enables an authenticated PAN-OS administrator with restricted privileges to use a compromised XML API key to perform actions as a higher privileged PAN-OS administrator beyond what the XML API permits.

🎯 Affected products3

  • PAN-OS
  • Cloud NGFW
  • Prisma Access

✅ Remediation

This issue is fixed in PAN-OS 10.1.11, PAN-OS 10.2.8, PAN-OS 11.0.3, and all later PAN-OS versions. Workarounds and mitigations: This issue requires the attacker to have authenticated access to the PAN-OS XML API. You can mitigate the effect this issue has on your environment by following the Administrative Access Best Practices in the PAN-OS technical documentation at https://docs.paloaltonetworks.com/best-practices. Each XML API key is associated with a specific user. XML API keys are not meant to be shared between users.

🔗 References (1)