CVE-2023-23919HighCVSS 7.5

A cryptographic vulnerability exists in Node.js <19.2.0 <18.14.1 <16.19.1 <14.21.3 that in some cases did does not clear the OpenSSL error stack after operations that may set it. This may lead to false positive errors during subsequent cryptographic operations that happen to be on the same thread. This in turn could be used to cause a denial of service.

Published
February 27, 2023
Last Modified
—

🔗 CVE IDs covered (1)

📋 Description

Is Azure Linux the only Microsoft product that includes this open-source library and is therefore potentially affected by this vulnerability? One of the main benefits to our customers who choose to use the Azure Linux distro is the commitment to keep it up to date with the most recent and most secure versions of the open source libraries with which the distro is composed. Microsoft is committed to transparency in this work which is why we began publishing CSAF/VEX in October 2025. See this blog post for more information. If impact to additional products is identified, we will update the CVE to reflect this.

🎯 Affected products2

  • cbl2 nodejs 16.19.1-1 on CBL Mariner 2.0
  • cm1 nodejs 14.21.3-1 on CBL Mariner 1.0

✅ Remediation

KBCBL-Mariner Releases (Security Update) — fixed build 14.21.3-1 KBCBL-Mariner Releases (Security Update) — fixed build 16.19.1-1

🔗 References (2)