CVE-2019-13638HighCVSS 7.8

GNU patch through 2.7.6 is vulnerable to OS shell command injection that can be exploited by opening a crafted patch file that contains an ed style diff payload with shell metacharacters. The ed editor does not need to be present on the vulnerable system. This is different from CVE-2018-1000156.

Published
September 25, 2020
Last Modified
—

🔗 CVE IDs covered (1)

📋 Description

Is Azure Linux the only Microsoft product that includes this open-source library and is therefore potentially affected by this vulnerability? One of the main benefits to our customers who choose to use the Azure Linux distro is the commitment to keep it up to date with the most recent and most secure versions of the open source libraries with which the distro is composed. Microsoft is committed to transparency in this work which is why we began publishing CSAF/VEX in October 2025. See this blog post for more information. If impact to additional products is identified, we will update the CVE to reflect this.

🎯 Affected products3

  • azl3 patch 2.7.6-9 on Azure Linux 3.0
  • cbl2 patch 2.7.6-7 on CBL Mariner 2.0
  • cm1 patch 2.7.6-7 on CBL Mariner 1.0

✅ Remediation

KBCBL-Mariner Releases (Security Update) — fixed build 2.7.6-7 KBCBL-Mariner Releases (Security Update) — fixed build 2.7.6-9

🔗 References (2)