GHSA-w595-4975-gm3hMediumCVSS 6.1
Apache Geode web-api is vulnerable to Cross-site Scripting
🔗 CVE IDs covered (1)
📋 Description
Malicious script injection ('Cross-site Scripting') vulnerability in Apache Geode web-api (REST). This vulnerability allows an attacker that tricks a logged-in user into clicking a specially-crafted link to execute code on the returned page, which could lead to theft of the user's session information and even account takeover.
This issue affects Apache Geode: all versions prior to 1.15.2.
Users are recommended to upgrade to version 1.15.2, which fixes the issue.
🎯 Affected products1
- maven/org.apache.geode:geode-web-api:>= 1.1.0, < 1.15.2