GHSA-rp8m-h266-53jhMediumCVSS 4.7

python-apt Flawed Package Integrity Check

Published
May 24, 2022
Last Modified
September 26, 2023

🔗 CVE IDs covered (1)

📋 Description

python-apt only checks the MD5 sums of downloaded files in Version.fetch_binary() and Version.fetch_source() of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

🎯 Affected products5

  • pip/python-apt:< 0.8.3ubuntu7.5
  • pip/python-apt:>= 0.9.0, < 0.9.3.5ubuntu3
  • pip/python-apt:>= 1.0.0, < 1.1.0
  • pip/python-apt:>= 1.2.0, < 1.6.5ubuntu0.1
  • pip/python-apt:>= 1.7.0, < 1.9.0ubuntu1.2

🔗 References (4)