GHSA-f525-44xv-f2qjCriticalCVSS 9.8

Apache Tomcat - HTTP/2 no-authority bypass of strict SNI validation

Published
August 26, 2026
Last Modified
October 27, 2026

🔗 CVE IDs covered (1)

📋 Description

Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990.

This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120.

Users are recommended to upgrade to version 11.0.25, 10.1.59 or 9.0.121, which fix the issue.

🎯 Affected products6

  • maven/org.apache.tomcat:tomcat-coyote:>= 11.0.20, < 11.0.25
  • maven/org.apache.tomcat:tomcat-coyote:>= 10.1.53, <= 10.1.57
  • maven/org.apache.tomcat:tomcat-coyote:>= 9.0.115, < 9.0.121
  • maven/org.apache.tomcat.embed:tomcat-embed-core:>= 11.0.20, < 11.0.25
  • maven/org.apache.tomcat.embed:tomcat-embed-core:>= 10.1.53, <= 10.1.57
  • maven/org.apache.tomcat.embed:tomcat-embed-core:>= 9.0.115, < 9.0.121

🔗 References (12)