GHSA-c86r-9hm3-5pccunknown

Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. A user can...

Published
November 4, 2026
Last Modified
November 4, 2026

🔗 CVE IDs covered (1)

📋 Description

Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB.

A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable. 

This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12.

Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.

🔗 References (4)