GHSA-8pp6-5qpw-85g3LowCVSS 3.5

Magnesium-PHP Injection vulnerability

Published
November 5, 2023
Last Modified
November 14, 2023

🔗 CVE IDs covered (1)

📋 Description

** UNSUPPORTED WHEN ASSIGNED ** ** UNSUPPORTED WHEN ASSIGNED ** A vulnerability was found in Magnesium-PHP up to 0.3.0. It has been classified as problematic. Affected is the function formatEmailString of the file src/Magnesium/Message/Base.php. The manipulation of the argument email/name leads to injection. Upgrading to version 0.3.1 is able to address this issue. The patch is identified as 500d340e1f6421007413cc08a8383475221c2604. It is recommended to upgrade the affected component. VDB-244482 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

🎯 Affected products1

  • composer/floriangaerber/magnesium:< 0.3.1

🔗 References (6)