GHSA-7pq6-v88g-wf3wCriticalCVSS 9.1

Sentry's improper authentication on SAML SSO process allows user impersonation

Published
January 15, 2025
Last Modified
January 15, 2025

🔗 CVE IDs covered (1)

📋 Description

Impact

A critical vulnerability was discovered in the SAML SSO implementation of Sentry. It was reported to us via our private bug bounty program.

The vulnerability allows an attacker to take over any user account by using a malicious SAML Identity Provider and another organization on the same Sentry instance. The victim email address must be known in order to exploit this vulnerability.

Patches

  • Sentry SaaS: The fix was deployed on Jan 14, 2025.
  • Self-Hosted Sentry: If only a single organization is allowed (SENTRY_SINGLE_ORGANIZATION = True), then no action is needed. Otherwise, users should upgrade to version 25.1.0 or higher.

Workarounds

No known workarounds.

References

  • https://github.com/getsentry/sentry/pull/83407

🎯 Affected products1

  • pip/sentry:>= 21.12.0, < 25.1.0

🔗 References (5)