GHSA-78wr-2p64-hpwjHighCVSS 7.5

Apache Commons IO: Possible denial of service attack on untrusted input to XmlStreamReader

Published
October 3, 2024
Last Modified
January 31, 2025

🔗 CVE IDs covered (1)

📋 Description

Uncontrolled Resource Consumption vulnerability in Apache Commons IO.

The org.apache.commons.io.input.XmlStreamReader class may excessively consume CPU resources when processing maliciously crafted input.

This issue affects Apache Commons IO: from 2.0 before 2.14.0.

Users are recommended to upgrade to version 2.14.0 or later, which fixes the issue.

🎯 Affected products1

  • maven/commons-io:commons-io:>= 2.0, < 2.14.0

🔗 References (5)