GHSA-77cc-w3wm-6whpCriticalCVSS 9.8

dssp vulnerable to Improper Restriction of XML External Entity Reference

Published
January 6, 2023
Last Modified
October 20, 2023

🔗 CVE IDs covered (1)

📋 Description

A vulnerability classified as problematic was found in e-Contract dssp up to 1.3.1. Affected by this vulnerability is the function checkSignResponse of the file dssp-client/src/main/java/be/e_contract/dssp/client/SignResponseVerifier.java. The manipulation leads to xml external entity reference. Upgrading to version 1.3.2 can address this issue. The name of the patch is ec4238349691ec66dd30b416ec6eaab02d722302. It is recommended to upgrade the affected component. The identifier VDB-217549 was assigned to this vulnerability.

🎯 Affected products1

  • maven/be.e_contract.dssp:dssp-client:< 1.3.2

🔗 References (6)