GHSA-74vm-8frp-7w68CriticalCVSS 10.0
EPyT-Flow vulnerable to unsafe JSON deserialization (__type__)
🔗 CVE IDs covered (1)
📋 Description
Impact
EPyT-Flow’s REST API parses attacker-controlled JSON request bodies using a custom deserializer (my_load_from_json) that supports a type field. When type is present, the deserializer dynamically imports an attacker-specified module/class and instantiates it with attacker-supplied arguments. This allows invoking dangerous classes such as subprocess.Popen, which can lead to OS command execution during JSON parsing. This also affects the loading of JSON files.
Patches
EPyT-Flow has been patched in 0.16.1 -- affects all versions <= 0.16.0
Workarounds
Do not load any JSON from untrusted sources and do not expose the REST API.
Credits
EPyT-Flow thanks Jarrett Chan (@syphonetic) for detecting and reporting the bug.
🎯 Affected products1
- pip/epyt-flow:< 0.16.1
🔗 References (7)
- https://github.com/WaterFutures/EPyT-Flow/security/advisories/GHSA-74vm-8frp-7w68
- https://github.com/WaterFutures/EPyT-Flow/commit/3fff9151494c7dbc72073830b734f0a7e550e385
- https://nvd.nist.gov/vuln/detail/CVE-2026-25632
- https://github.com/WaterFutures/EPyT-Flow/releases/tag/v0.16.1
- https://github.com/pypa/advisory-database/tree/main/vulns/epyt-flow/PYSEC-2026-330.yaml
- https://pypi.org/project/epyt-flow
- https://github.com/advisories/GHSA-74vm-8frp-7w68