vllm
PyPI106 known CVEs affecting this package
Aggregated from OSV, GitHub Security Advisories, NVD, and vendor advisories. Each CVE links to its full detail page with vendor advisories, patches, fixed versions, and remediation guidance.
CVEs affecting vllmpage 3 of 3
- CVE-2026-94622HIGHCVSS 7.5EG 7.5fixed in 0.30.02026-09-21
vulnerable: 0.0.1 ... 0.9.2 (97 versions)
vLLM versions through 0.29.0 contain a denial of service vulnerability in the NIXL connector's metadata handling for prefill/decode disaggregated deployments. Attackers can send requests with incomplete kv_transfer_params dictionary entrie…
- CVE-2026-94623HIGHCVSS 7.5EG 7.5fixed in 0.30.02026-09-21
vulnerable: 0.0.1 ... 0.9.2 (97 versions)
vLLM through 0.29.0 contains a denial of service vulnerability in the NIXL connector's prefix caching implementation that fails to properly validate block counts across multi-prompt completion requests in prefill/decode disaggregated deplo…
- CVE-2026-94624MEDIUMCVSS 7.5EG 6.5fixed in 0.30.02026-09-21
vulnerable: 0.0.1 ... 0.9.2 (97 versions)
vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can supply arbitrary remote host and port va…
- CVE-2026-94625MEDIUMCVSS 5.3EG 5.3fixed in 0.30.02026-09-21
vulnerable: 0.0.1 ... 0.9.2 (97 versions)
vLLM through 0.29.0 contains a resource exhaustion vulnerability in MooncakeConnector where rejected prefill requests create ownerless transfer placeholders that are never reclaimed. Attackers can send rejected requests to exhaust sender t…
- CVE-2026-94626HIGHCVSS 7.5EG 7.5fixed in 0.30.02026-09-21
vulnerable: 0.0.1 ... 0.9.2 (97 versions)
vLLM through 0.29.0 fails to validate the tp_size parameter in kv_transfer_params on OpenAI-compatible completion endpoints, allowing attackers to allocate unbounded memory. Attackers can supply arbitrary tp_size values in prefill/decode d…
- CVE-2026-9540MEDIUMCVSS 5.3EG 5.32026-05-26
vulnerable: 0.0.1 ... 0.9.2 (81 versions)
A vulnerability was identified in vllm-project vllm 0.19.0. This issue affects some unknown processing of the component OpenAI-compatible Serving Path. Such manipulation leads to denial of service. It is possible to launch the attack remot…
Check whether vllm is used in your infrastructure
EchelonGraph scans your cloud and SBOMs to map every package to your actual deployments. See blast radius for vllm CVEs against the assets you own.
Book a Demo →