postcss-selector-parser
npm2 known CVEs affecting this package
Aggregated from OSV, GitHub Security Advisories, NVD, and vendor advisories. Each CVE links to its full detail page with vendor advisories, patches, fixed versions, and remediation guidance.
CVEs affecting postcss-selector-parserpage 1 of 1
- CVE-2026-104844MEDIUMCVSS 5.9EG 5.9fixed in 7.1.62026-10-02
PostCSS Selector Parser is a CSS selector parser that integrates with PostCSS but does not require it. Prior to 7.1.6, src/parser.js splitWord() can receive a flat selector as one word token carrying many class or ID indexes because period…
- CVE-2026-9358MEDIUMCVSS 4.3EG 4.3fixed in 6.1.3 or 7.1.3, by version range2026-05-24
A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled rec…
Check whether postcss-selector-parser is used in your infrastructure
EchelonGraph scans your cloud and SBOMs to map every package to your actual deployments. See blast radius for postcss-selector-parser CVEs against the assets you own.
Book a Demo →