codewhale
npm9 known CVEs affecting this package
Aggregated from OSV, GitHub Security Advisories, NVD, and vendor advisories. Each CVE links to its full detail page with vendor advisories, patches, fixed versions, and remediation guidance.
CVEs affecting codewhalepage 1 of 1
- CVE-2026-75856HIGHCVSS 8.6EG 8.6fixed in 0.8.642026-08-18
CodeWhale before 0.8.64 contains a server-side request forgery bypass vulnerability in DNS pinning logic that fails to prevent time-of-check-time-of-use attacks. Attackers can manipulate DNS responses to fail initial resolution checks and …
- CVE-2026-75857HIGHCVSS 7.0EG 7.0fixed in 0.8.642026-08-18
CodeWhale versions >= 0.3.10 and < 0.8.64 (published as deepseek-tui >= 0.3.10 and < 0.8.41 on npm and 0.3.10 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain a vulnerability in the exec_shell_i…
- CVE-2026-75858HIGHCVSS 7.8EG 7.8fixed in 0.8.642026-08-18
CodeWhale (packages codewhale / codewhale-tui) versions >= 0.8.41 and < 0.8.64 contain a remote code execution vulnerability in the rlm_eval tool. The tool's approval_requirement() returns ApprovalRequirement::Auto, which the engine treats…
- CVE-2026-75859HIGHCVSS 7.5EG 7.5fixed in 0.8.642026-08-18
CodeWhale versions before 0.8.64 fail to validate file paths in the project config instructions field, allowing attackers to read arbitrary files on the victim's system. A malicious .codewhale/config.toml file in a cloned repository can sp…
- CVE-2026-75911HIGHCVSS 7.8EG 7.8fixed in 0.8.642026-08-18
CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml f…
- CVE-2026-75912HIGHCVSS 7.4EG 7.4fixed in 0.8.642026-08-18
CodeWhale versions before 0.8.64 contain an argument injection vulnerability in the git_blame tool that allows attackers to read arbitrary files by injecting git options into the unvalidated rev parameter. Attackers can supply rev values l…
- CVE-2026-75913CRITICALCVSS 9.3EG 9.3fixed in 0.8.642026-08-18
CodeWhale versions >= 0.3.27 and < 0.8.64 (published as deepseek-tui >= 0.3.27 and < 0.8.41 on npm and 0.3.27 through 0.8.41 on crates.io, and as codewhale / codewhale-tui >= 0.8.41 and < 0.8.64) contain an argument injection vulnerability…
- CVE-2026-75914HIGHCVSS 7.5EG 7.5fixed in 0.8.642026-08-18
CodeWhale versions before 0.8.64 contain a path traversal vulnerability in the image_analyze tool that fails to canonicalize symlinks before reading files. Attackers can create workspace symlinks pointing to external files with image exten…
- CVE-2026-75915HIGHCVSS 7.5EG 7.5fixed in 0.8.642026-08-18
CodeWhale versions before 0.8.64 contain an environment variable exposure vulnerability in the js_execution tool that fails to scrub parent process environment variables before spawning Node.js. Attackers can craft malicious JavaScript cod…
Check whether codewhale is used in your infrastructure
EchelonGraph scans your cloud and SBOMs to map every package to your actual deployments. See blast radius for codewhale CVEs against the assets you own.
Book a Demo →